1. Knowing interface

Gladivs-SSC is so simple that its interface is based on a menu bar, a toolbar and most of the surface of the window, which contains the screen shot. Now we look at the menu bars and tools:

Below, we detail the menus and the toolbar.

Menu bar:

  • File:
    • Save as: Opens a window that allows us to find the folder where you want to save the image. It also allows us to choose a name for the file.
    • Minimize to tray: minimizes application and left running in the background. We may reopen the application from the application menu in the background, which can be accessed by pressing the arrow ^ next to the clock and select the application icon.
      Note: instructions and pictures corresponds to Windows 10, for other platforms, the procedure is similar. We can also recover the application if you click the [Print Screen.] button in your keyboard (under the [Delete] and [Insert] keys).

    • Close: closes the application completely. This action causes the [Print Screen] button not opens Gladivs-SSC.
  • Window
    • Settings: We can modify the different parameters of the application.
  • Help
    • Help: shows this file.
    • About: show information about the application.

Toolbar:

  • New capture: Take a snapshot of your screen and displays it in the window.
  • Dimensions: lets you choose the size of the image stored on disk. It has no effect on the displayed image.
  • Constrain proportions: blocks proportionality of image. If you activate this button, as we modify the value of any of the fields, the other is automatically calculated keeping the aspect ratio of the original image.
  • Output format: from this menu you can choose the format that has the image to be saved. Available formats are: gif, jpeg, png, tiff i bmp.
  • Restore original values of the capture: this button allows you to recover the original values of the capture. This is useful if, for example, you have changed these settings and you want to return to the original.
  • Save capture: saves the capture shown in the window with the dimensions and formats selected in the default directory. The default directory path can be changed from the menu Application>Settings.

 

Within the notification area, if you click with the right mouse button in the Gladivs-SSC icon, a context menu opens like this:

The options in this menu are:

  • Restore: Opens the application window.
  • Capture: Take a new screen capture.
  • Exit: closes the application completely. This action causes the [Print Screen] not opens Gladivs-SSC..

 

2. Taking and saving captures

Gladivs - SSC by default, is installed with the auto-start every time the system starts. This means that the application is available, running in the background, so when we need it. For the functionality of the [Print Screen] button is active is necessary that the application is running.


To take a new capture we have three options:

  • Press the icon in toolbar
  • Press the [Print Screen.] button on your keyboard.
  • Select the option Capture in the contextual menu of the notification icon..

To save a capture, click on the icon.  The image is saved in the default directory. If you want to change this directory you can do this from the Window>Settings menu.

You can also save the image to the desired location without having to change settings. The Save As from the File menu lets you save the image where you want with the name you want.

Format options and dimensions

Optionally you can choose the format in which the image is saved to disk. This can be done from the format selection menu , you'll find the in the toolbar.
You can also choose the size that the image will be saved . With the button you can lock the proportionality of the image. For example, if you want to save the image with a not proportional dimensions, you must leave the button off () and write the desired dimensions (width and height).

Conversely, if you want to keep proportions while resizing the image, then you should lock the button pressing on it, its state changes to indicate that it has locked (). Now change the value you want. For example, if you want your capture is saved with a width of 560 pixels, then you must write this value in the Width field, the program automatically calculates the Height of the image while retaining the original proportions of the image. This procedure can be done in reverse, that is, by the same procedure, you can modify the heightof the image for the program to automatically calculate the width

In any case, if for whatever reason, you want to return to the original values of the capture, which match the resolution of your monitor, you can do so by simply pressing the button Restore original values:

Note: If you do not keep an image and take a new snapshot, the earlier will be overwritten and can not recover. Anyway, the program will ask you to save the image if you had not previously saved, before making a new one.
You can also select the Auto-save option in the Window>Settings menu. This will prevent the program asks you each time you make a new capture i automatically save the last.

 

3. Settings and languages

In the Window>Settings menu, you have these options:

  • Default save path for captures: to change it, click the Browse button and select the folder where you want to save the images.
  • Enable or disable auto-saving: check to enable the automatic saving. Uncheck to disable auto save.
  • Change the language of the application: select the language you want from those available in the dropdown menu. As you change the language of the application it is necessary to reboot Gladivs-SSC. You can automatically restart at that moment or do it manually later.
To save all your changes, click the Save button. The settings are saved and the window will close automatically


To cancel press the Cancel button. This action will close the window and ignore any change that would have been do.

 

4. Information

This file is the official software reference.

Created by Guillermo Espert Carrasquer and originally written in Catalan..

Version 0.4 of this document at November 8, 2015

Icons made by Dave Gandy and other autors from www.flaticon.com is licensed by CC BY 3.0

Icons made by Elegant Themes, Icomoon, Appzgear from www.flaticon.com is licensed by CC BY 3.0

Both the application and its documentation and all its components are distributed under the Apache 2.0 license that can be found on this link: http://www.apache.org/licenses/LICENSE-2.0

 

5. Acknowledgments

To create this application have been used free versions of the following programs and services:

  • Visual Studio 2015 comunity edition de Microsoft, coding IDE.
  • Inno Setup de JR software, installation packages compiler.
  • Inno Script Studio de Kymoto Solutions, installation packages editor.
  • Flaticons icons used in the application..
  • Freeimages images used in the web site.
  • Surceforge is the project hosting.
  • Maher Jarrah creator of the theme of web site.
  • Laravel framework used to run this web site.